Форум » [x]Harbour » Вопрос по Excel ? » Ответить

Вопрос по Excel ?

Andrey: Всем привет. Вопрос к знатокам Excel-я, как подсчитать сумму ВСЕХ значений с минусом и с плюсом ? Вот есть таблица из многих столбцов. Как сделать формулу для расчёта этих значений по 2-му столбцу ?

Ответов - 92, стр: 1 2 3 4 5 All

Softlog86: Как красиво :)

Alex_Cher: Мужики... кто нибудь пробовал из Harbor создавать графики в Excel ..? Подскажите пару команд ....

Dima: Alex_Cher C:\MiniGUI\SAMPLES\BASIC\OLE\ + http://clipper.borda.ru/?1-2-0-00000033-000-0-0-1179749939


Alex_Cher: Наткнулся на "грали" .... помогите... вводим в ячейку excel данные oWorkBook:Cells( line, massiv[_i]) := 135 Можно ли из Harbor определить адрес данной ячейки в формате excel для использования фомулах, допустим =СУММ(N8: .....) или как это можно оботи ?

Pasha: Function ExcelAdr(nRow, nCol) Return if(nCol>26,Chr(Int((nCol-1)/26)+64),'')+Chr((nCol-1)%26+65) + StrTrim(Int(nRow))

Alex_Cher: Pasha, спасибо тебе большое ... не думал что так все просто. Только в конце команды я немножко подправлю. Вместо + StrTrim(Int(nRow)) .... + Allrtim( Str( Int( nRow))) Функция StrTrim() по моему была в Clipper, в Harbor ее нет...

Dima: Alex_Cher пишет: + Allrtim( Str( Int( nRow))) Hb_ntos(nRow)

Pasha: Alex_Cher пишет: Функция StrTrim() по моему была в Clipper, в Harbor ее нет... Прошу прошения, это моя функция Function StrTrim(n) Local c := AllTrim(Str(n)) if At('.', c) # 0 c := RemRight(c, '0') c := RemRight(c, '.') endif Return c

Alex_Cher: Мужики, кто плотно с excel работает через Harbor? Над элементарной хренью бьюсь часами... Документации нет, из макросов нихрена ничего не понятно... Короче ячейку обвести рамкой все понятно - oWorkBook:Ceels( 3,12):Borders():Weight := 3 А как обвести группу ячеек одной рамкой ? oWorkBook:Range( oWoorkBook:Ceels( 3,12), ......... ):Borders():Weight := 3 обводит рамкой каждую ячейку, не подходит...

Dima: как то так oSheet:Range(osheet:cells(i,1),osheet:cells(i+3,2)):BorderAround( xlContinuous, xlThin)

Alex_Cher: Dima, спасибо за помощь... Поделись где копаешь документацию?

Dima: Alex_Cher пишет: Поделись где копаешь документацию? на форуме ищу и гуглю



полная версия страницы